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This guide describes how to use the Agilent MassHunter Workstation Software 
Report Designer Add-in.

Where to find more information
Use the online Help for in-depth information not given in this Quick Start 
Guide. 

• For Excel 2003, the Report Design menu is in the main menu. 

• For Excel 2007, the Report Design menu is in the Menu Commands group 
in the Add-Ins tab of the Ribbon. The MassHunter Reporting Toolbar is 
visible in the Custom Toolbars group in the Add-Ins tab of the ribbon.

Open online Help in either of the following ways:

• Click Report Design > Help from the Excel menu.

• Click the  button in the MassHunter Reporting toolbar.
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What is the Agilent MassHunter Workstation Software Report Designer Add-in?
What is the Agilent MassHunter Workstation Software Report Designer 
Add-in?

Agilent MassHunter Workstation Software Report Designer Add-in lets you 
modify the templates that are used for printing reports from the following 
Agilent programs:

• Agilent MassHunter Workstation Software - Quantitative Analysis program

• Agilent MassHunter Workstation Software - Qualitative Analysis program

• Agilent MassHunter Workstation Software - Data Acquisition program

• Agilent MassHunter Workstation MetaboliteID

• Agilent MassHunter Workstation Software - ICP-MS program

The Report Designer is an add-in tool for Microsoft Excel 2007. It also 
supports Microsoft Excel 2003 software. This tool allows you to:

• Create a new template or modify an existing template

• Add tables and graphics to a template

• Add additional columns to existing tables

• Repeat tables and graphics for all peaks or compounds in the data

• Use standard Excel features to customize the report

This tool is automatically installed with the software listed above.

Watch cursor shapes

The shape of the cursor indicates what action can be done.

• The thick plus sign is the selection icon. You can select cells, columns or 
rows.

• The thin plus sign with arrows at the end is the move icon. It is used to 
move table columns in a table.

• The insertion bar shows where the column will be inserted in a table.
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Report Designer UI elements

The following features are available in the Agilent MassHunter Workstation 
Software Report Designer Add-in.

Report Design menu/toolbar
For Excel 2003, the Report Design menu is added to the main menu, and the 
Report Design toolbar is shown with the other available toolbars. 

For Excel 2007, the Report Design menu is available in the Menu Commands 
group in the Add-Ins tab in the Ribbon. The Report Design toolbar is shown in 
the Add-Ins tab in the Ribbon.

Process Report This command opens the Process Report dialog box. After you 
select a report results file, a report is generated which you can review to verify 
any changes that you made. The report is shown in a worksheet within Excel.

Clear Results This command removes the report worksheets generated by 
creating a report. It also removes the results from the design sheets. You click 
this command when you want to return to examine the template.

Add Data menu These commands add different types of tables to the 
template. Different applications have different tables that you can add.

Add Graphics menu These commands add graphics to the current location in 
the template. Different applications have different graphics that you can add.

Add Formatting menu These commands add a page break or a sheet break. You 
can also select a section in the template and then click Repeat Section to add 
the commands lines to repeat that section.

Validate Design This command checks that the template design is valid. The 
Validation Results dialog box displays the results.

Advanced Properties dialog box This command opens the Advanced Properties 
dialog box. See “Advanced Properties dialog box” on page 4 for more 
information.
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Advanced Properties dialog box
The information in this dialog box is separated onto four different tabs. See 
the online Help for detailed information.

Template tab In this tab, you select the template type on this tab. Each 
program supports one or more possible template types. You need to match the 
template type with the type of report you are trying to create.

Design Worksheet tab In this tab, you mark whether or not the worksheet is a 
design worksheet and whether or not to exclude this sheet from the report. 

Cell tab In this tab, you select properties for a single cell. You click whether 
the cell contains text or graphics. If you are displaying the graphic, you can 
specify the size of the graphic relative to the page width. You can associate a 
cell with the following table or graphics which ensures that a cell appears on 
the same page as the table or graphics below it.

Table tab In this tab, you can select many properites for a table or a column 
within a table. You can hide the header row or specific columns, or you can 
select to show a table vertically instead of horizontally. Also, you can associate 
a table with the following table or graphics. In addition, you can set a filter for 
one of the columns in the table. See the online Help for more information.
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Getting Started

Basic Tasks

• “To open a template” on page 6

• “To save a template” on page 7

• “To save a template to a new name” on page 7

• “To verify changes in a report” on page 8

• “To create a new template” on page 9

• “To enable toolbar/menu” on page 9

• “To change a template to use A4 paper” on page 10

• “To set the width of a column in a table” on page 11

• “To set global parameters for the template” on page 11
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To open a template

1 Open the Windows Explorer program.

2 Open the Report Templates folder in the folder where you installed the data.

3 Open the folder that contains the templates that you want to modify.

For the Quantitative Analysis program and the Qualitative Analysis 
program, you also need to open either the Letter or A4 folder. The templates 
in the Letter folder are designed to be printed on letter size paper. The 
templates in the A4 folder are designed to be printed on A4 paper.

4 Right-click the file name and then click Open.

Program Folder

Quantitative Analysis Quant/Letter or Quant/A4

Qualitative Analysis Qual/Letter or Qual/A4

Data Acquisition - Method AcquisitionMethod

Data Acquisition - Tuning for TOF instrument TOF/tune

Data Acquisition - Tuning for Q-TOF instrument QTOF/tune

Data Acquisition - Tuning for QQQ instrument QQQ/tune

Template Directories

NOTE If you open the template by double-clicking the file name, the template is opened as a work-
book (.XLS) instead of as a template (.XLT). You need to remember to change the Save as 
Type field to template before you save the template.

NOTE If you opened a template which was shipped with the product, you must immediately save 
the template with a different name. Otherwise, you will overwrite the changed template if 
you reinstall the software.
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To save a template
Some programs let you select which template to use. If you are able to change 
the name of the template that is used, you do not change the templates that 
are shipped with the software. Instead, you save the template to a different 
name and modify this template. Then, if you need to reinstall the software, you 
will not overwrite the template that has your changes. You can select which 
template to use for these programs:

• Quantitative Analysis program - all templates

• Qualitative Analysis program - Analysis report, Compound report, 
Qualitative method report, and Acquisition method report

If you cannot select which template to use, you make a backup of the original 
template before changing it. Also, when you have completed your changes, you 
make a backup of the changed template. Then, if you reinstall the software, 
you will have a backup of any changes that you made.

1 Click Save.

For Excel 2003, this command is in the File menu.

For Excel 2007, this command is in the Microsoft Office Button menu.

To save a template to a new name
1 Open the Save As dialog box.

For Excel 2003, click Save As in the File menu.

For Excel 2007, click Microsoft Office Button and then point to the arrow 
next to the Save As command and click Other Formats.

2 Change the Save as type.

For Excel 2003, select Template (*.xlt) as the Save as type.

For Excel 2007, select Excel 97-2004 Template (*.xlt) as the Save as type.

3 Open the folder with the installed templates.

The templates are installed in a folder in the MassHunter/Report Templates 
folder. 
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4 In the Save As dialog box, type a new File name.

5 Click Save.

To verify changes in a report
After you have created a new template or modified an existing template, you 
first validate the template and then create a report using this template. 
Validating the template checks for some errors that can exist in the template. 
Creating a report also shows you if any errors exist and shows you if the 
report template is designed the way you want it to look.

• For Excel 2003, the Report Design menu is in the main menu. 

• For Excel 2007, the Report Design menu is in the Menu Commands group 
in the Add-Ins tab of the Ribbon. The MassHunter Reporting Toolbar is 
visible in the Custom Toolbars group in the Add-Ins tab.

1 Click Validate Design in the Report Design menu. 

The Validation Results Dialog Box is opened. You can also click the 
 icon in the Report Design toolbar.

2 Read the list of problems in the Validation Results dialog box. Fix any 
problems that it finds. Click Close when you are finished.

3 Click Report Design > Process Report. The Process Report Dialog Box is 
opened. You can also click the Process Report icon in the MassHunter 
Reporting Toolbar.

4 Click the Browse button to open the Open dialog box. You need to select a 
results file that was created for this data file. You use this dialog box to 
switch to the folder for the intermediate report files that you want to use.

5 Select the intermediate reports folder and file.

For the Qualitative Analysis program, you can save the results of any report 
that you create. 

a In the Qualitative Analysis program in the Intermediate Report Files 
dialog box, mark the Keep intermediate report directories check box.

NOTE The add-in expects to find the schema file in the same folder as the templates. If you want 
to put your new templates into a different folder, you need to copy the schema file to the 
new folder. For the Quantitative Analysis program, this schema file is batch.results.xsd. For 
the Qualitative Analysis program, the schema file is one of the following: Qualita-
tiveMethodReport.xsd, Graphic.xsd, CompoundReport.xsd, or AnalysisReport.xsd.
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b Select the folder to use to store these report directories. By default, this 
value is set to the “\\MassHunter\reports\temp” folder.

c Select the file Report.xml. If you have not created a report for this type of 
template, you are not able to process the new or changed report 
template. In that case, you need to use the Qualitative Analysis program 
to generate a report first.

For the Quantitative Analysis program, results are created when you 
generate a report within the Quantitative Analysis program. The results file 
name for Quantitative Analysis is report.results.xml. This file is found in one 
of the directories in the QuantReports folder that is in the Batch folder. 

6 Click Open.

7 Click OK in the Process Report dialog box.

The events which occur during processing are 

• Data is imported to the design sheets. 

• Data is filtered and copied to report sheets. 

• Data is formatted. 

• Graphics are imported. 

Review the report that is generated. It will be opened in one or more sheets 
within Excel. When you are done reviewing the report, click Report Design > 
Clear Results or click the  icon in the Reporting Designer 
Toolbar 

To create a new template
1 Do the steps in “To open a template” on page 6. Open a template that you 

can use to start a new template.

2 Do the steps in “To save a template to a new name” on page 7.
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To enable toolbar/menu

The toolbar and menu are disabled if no template is open or if a different 
add-in is being accessed. To enable the toolbar, load a template.

If a template is loaded and the toolbar and the menu are still disabled, do 
these steps:

1 Open the Add Ins dialog box.

• For Excel 2003, click Tools > Add-ins in the main menu. 

• For Excel 2007, do the following:

a Click the Microsoft Office Button and then click Excel Options.

b In the Excel Options dialog box, click Add-Ins. 

c Select Excel Add-ins in the Manage list box.

d Click Go.

The MassHunter Reporting Add-ins are listed in the Add-Ins available list.

2 Mark the check box for the MassHunter Reporting Add-In that you use. For 
example, mark the Masshunter Reporting Qual check box if you will 
change a Qualitative Analysis template.

3 Click OK.

4 Restart Microsoft Excel.

To change a template to use A4 paper
The Qualitative Analysis program and the Quantitative Analysis program 
include templates that can be used with A4 paper. If you want to change a 
report to print on A4 instead of letter, do the following:

1 Do the steps in “To open a template” on page 6.

2 Do the steps in “To save a template” on page 7.

3 Open the Page Setup dialog box.

For Excel 2003, click File > Page Setup.

For Excel 2007, click Margins > Custom Margins in the Page Setup group in 
the Page Layout tab of the Ribbon.
10 Agilent MassHunter Report Designer Add-in Quick Start Guide



Getting Started
4 Select A4 in the Paper size list box on the Page tab.

5 Click the Margins tab. Set the margins depending on whether you print in 
Landscape or Portrait mode.

6 Click OK.

To set the width of a column in a table
You cannot set the width of a column in a table by changing the width of the 
Excel column. Instead, you want to set the width for that column within the 
table. You can set a different width for each column in each table. You use the 
Width comments when

• You are trying to align columns which may vary widely between datasets.

• The strings that print in the report may be long and push other columns off 
of the report page.

• You want more white space.

• The data appears clipped.

1 Select a cell in one of the tables that you’d like to set to a different width.

2 Right-click that cell and click Insert Comment, Update Comment or Edit 
Comment.

3 Type Width(15) as the comment. You can use a larger number if you want 
the width of that column to be wider. The word Width is case-sensitive. Each 
narrow column in the report is 2.5 units.

Parameter Landscape setting Portrait setting

Top 1.1 1.1

Header 0.7 0.7

Left 0.75 0.7

Right 0.75 0.7

Bottom 1 1

Footer 0.6 0.6
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To set global parameters for the template
The global options on this worksheet are only used if the value for Use 
Options is TRUE.

1 Switch to the Options worksheet.

2 Select TRUE as the Value for the Use Options parameter.

3 Select whether or not to Include Header on each page of the report.

4 Select whether or not to Include Footer on each page of the report.

5 Select whether or not to print the report in Landscape mode. If this value is 
FALSE, then the report is printed in Portrait mode.

You can also set additional values. Some of these values are not used by the 
report now.

NOTE If you apply the Width comment to a column in a table that is transposed, then the Width 
comment is only applied to the value. The column header is lined up with the other columns 
in the table.
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Customizing a template

The following tasks show you how to format the template.

• “To set the formatting for a cell in a table” on page 13

• “To change the header or footer” on page 14

• “To rename a column in a table” on page 15

• “To delete a column in a table” on page 15

• “To add a column to an existing table” on page 15

• “To add a mapped column to an existing table” on page 16

• “To add an element from the dataset more than one time” on page 17

• “To add a filter to an existing table” on page 17

• “To add a graphic to an existing template” on page 18

• “To add a table to an existing template” on page 19

• “To repeat a section” on page 19

• “To add a formula column to an existing table” on page 19

• “To move a column in a table” on page 20

• “To move a column in a filtered table” on page 20

• “To add formatting to an existing template” on page 21

• “To change time and date format” on page 21

To set the formatting for a cell in a table
Most formatting of a cell is done using standard features in Excel. 

If you want to change the format of a cell if it is outside of a certain range, you 
add Conditional Formatting.

Formatting

1 Select a column in the table. You usually select the header and the cell 
below it so that the formatting is consistent.

2 Use Excel to set the format for this column.

The standard format is that numbers are right-aligned, and text values are 
left-aligned. You can also select the font, color and size of the text using 
standard Excel features.
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Conditional Formatting

3 Select the cell in the table. It is very important to select the cell below and 
not the column header.

For Excel 2003 4 Click Format > Cell to use Excel to add formatting. In the Number tab, you 
can specify whether the value is opened as Text, Numeric, General or 
Custom.

5 Click OK when you have finished making changes.

6 Click Format > Conditional Formatting to change the format of the cell 
based upon its value.

For Excel 2007 4 Click the Home tab in the Ribbon.

5 Click the fields in the Number group to change the format of the cell. You 
can also click Format Cells in the shortcut menu to open the Custom Lists 
dialog box.

6 Click Conditional Formatting > New Rule in the Styles group to change the 
format of the cell based upon its value.

To change the header or footer
You can change the header or footer of the report to show a different company 
logo or to change the title of the report.

For Excel 2003 1 Click View > Header and Footer. The Page Setup dialog box is opened with 
the Header/Footer tab selected.

2 Click the Custom Footer button to edit the footer.

3 In the Left section, select &[Picture].

4 Click the New Picture icon.

5 Click Replace to change the picture.

6 In the Insert Picture dialog box, select the new picture you wish to include 
as part of the footer.

7 Click Insert.

8 Repeat steps 1 to 7 for each design tab.

For Excel 2007 1 Click Page Layout in the Workbook Views group in the View tab in the 
Ribbon.

In the Page Layout view, the Header and the Footer are displayed.
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2 Double-click on the section of the header or footer you want to modify. The 
header and the footer each have three sections: left, middle and right.

You can type a new value into the selected section. You can also click the 
icons in the Header & Footer Elements group in the Design tab of the 
Ribbon. This tab is automatically shown after you double-click on a section 
of the header.

3 Click Normal in the Workbook Views group in the View tab in the Ribbon to 
return to the original view of the worksheet.

You can press the F1 function key to get additional help on changing the 
header and footer. 

Changes to the header/footer must be made on each design worksheet.

To rename a column in a table
The header name for a column by default is the XML dataset element name. 
The header name can be safely changed to whatever is desired including 
another language as long as it is unique.

1 Click on the header for a column.

2 Type a new name. If you change the name of this column to the same name 
as an existing column, the existing column will be automatically renamed. 
For example, the column Delta is renamed Delta2.

3 (optional) If you need to have two different columns have the same name, 
change the coloring of the unique part of the name to white.

To delete a column in a table
1 Right-click the column header that you want to delete.

2 For Excel 2003, click Delete > Column.

3 For Excel 2007, click Delete > Table Columns.

You cannot press the DEL key to delete the column. If you do, the column 
name is renamed to the XML dataset element name.
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To add a column to an existing table

1 Right-click the column header at the desired insertion point. The column is 
inserted to the left of the selected column.

For Excel 2003, click Insert > Column.

For Excel 2007, click Insert > Table Columns to the Left.

2 Change the column header name. By default, the header name is set to 
“Column1”. The 1 in the header name is incremented if that column name 
already exists.

To add a mapped column to an existing table
1 Open the XML map for the dataset.

For Excel 2003, click Data > XML > XML Source. You can also right-click 
one of the mapped columns and click XML > XML Source.

For Excel 2007, right-click one of the mapped columns and click XML > 
XML Source.

2 Click a field in the table to which you want to add a column.

3 Click a different field in the same table. 

4 In the XML Source window, select the column you want to add to a table. 
Make sure that the new column is in the same table as the field you selected 
in steps 4 and 5.

5 Click the column in the XML Source window and drag it to the end of the 
table. Place the new column in the same row as the other column labels. You 
cannot replace a mapped column in the table.

6 Change the font color of the newly added column to Automatic. 

For Excel 2003, you click the toolbar icon  in the Formatting toolbar.

For Excel 2007, you click the icons in the Font group in the Home tab in the 
Ribbon.

NOTE Click two different fields in the same table. Clicking on the second field actually scrolls the 
selected field in the XML source into view. Instead of clicking a different field in the same 
table, you can use the scroll bar in the XML Source window to display the selected field.
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7 If you want that column in a different location, see “To move a column in a 
table” on page 20.

8 Do the steps in “To save a template” on page 7.

You must map elements from the same dataset table into the same Excel table. 
If you try to map a column from a different table in the dataset, an error 
message is displayed which states “The operation cannot be completed 
because the XML list is bound to a different XML map.”

To add an element from the dataset more than one time
An element in the dataset can only be mapped once in an entire report. You 
can add another XML map of the same dataset and map elements from that 
map instead.

1 Open the XML map for the dataset.

For Excel 2003, click Data > XML > XML Source. You can also right-click 
one of the mapped columns and click XML > XML Source.

For Excel 2007, right-click one of the mapped columns and click XML > 
XML Source.

The XML map for the dataset is displayed.

2 Click the XML Maps button in the XML Source window.

3 Click the Add button in the XML Maps dialog box.

4 Navigate to and select the report schema. For Qualitative Analysis reports 
and Quantitative Analysis reports, this file is in the same folder as the 
templates.

5 Click Open.

6 Click OK. A new map is added and is ready for use.

7 Select the XML map to use in the XML maps in this workbook list.

8 Do the steps in “To add a mapped column to an existing table” on page 16.
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To add a filter to an existing table

1 Click the arrow on the cell in a table to which you want to apply a filter.

2 Open the Custom Filters dialog box.

For Excel 2003, select Custom from the list.

For Excel 2007, select Text Filters > Custom Filters from the list.

3 Select the type of comparison you want to do on the cell you selected. You 
can select equals, does not equal, is greater than, is greater than or equal 
to, is less than, is less than or equal to, begins with, does not begin with, 
ends with, does not end with, contains or does not contain.

4 Type the value to use in the comparison.

5 Click either the And button or the Or button. If you click the And button, 
then both conditions need to be met before the row is included in the table. 
If you click the Or button, then if either condition is met, then the row is 
included in the table.

6 Select the second type of comparison you want to do on the cell you 
selected.

7 Type the value to use in the second comparison.

This filter is very useful when creating outlier tables. The first comparison can 
check if the outlier is equal to Low. The second comparison can check if the 
outlier is equal to High. If you click the Or button, then the table would contain 
both Low and High outlier values.

In Excel 2003, columns that have been filtered have a blue arrow instead of a 
black arrow. In Excel 2007, columns that have been filtered have a filter 
symbol instead of a black arrow. 

Also, a filtered table will have a collapsed row below the header row.
18 Agilent MassHunter Report Designer Add-in Quick Start Guide



Customizing a template
To add a graphic to an existing template

The Add Graphics menu and the Add Formatting menu are both in the 
Report Design menu.

1 Click the location where you want the graphic added. 

2 Click one of the commands in the Add Graphics menu to add a graphic to 
the template. For example, if you click Sample Chromatogram, then a 
sample chromatogram graphic is added to the template. You can add any of 
the graphics.

3 If you want this graphic to be repeated, do the steps in “To repeat a 
section” on page 19.

Adding many graphics to a report slows down the report’s processing speed 
considerably.

To add a table to an existing template
1 Select the location in the report to add a table. 

2 Click a command in the Report Design > Add Data menu to select which 
type of table to add to the template. This menu is only available for some 
applications.

3 Do the steps in “To add a mapped column to an existing table” on page 16 if 
you want to add additional columns to the table.

4 If you want this table to be repeated, do the steps in “To repeat a 
section” on page 19.
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To repeat a section

You can repeat any section in the template. This section can contain tables and 
graphics.

1 Select all the rows of the section that you want to repeat. If you want to 
repeat a table or a graphics section, make sure to select all of the rows of 
the table or the graphics table.

2 Then, click Add Formatting > Repeating Section. 

3 In the Select Column dialog box, select the ID to use to repeat the section 
and click OK. For example, to repeat the Sample Chromatogram, you select 
SampleID as the field to repeat.

The add-in automatically adds the following lines around the section you 
selected.

Before CMD: Repeat

After CMD:EndRepeat

The ID that is being used to repeat the section is shown at the end of both of 
those lines. If you want to repeat a section for each compound in the sample 
and for each sample in the results file, you add the repeating section twice.

To add a formula column to an existing table
1 Select a column in the table. The formula column is added to the right of 

this column.

2 Click Add Data > Formula Column from the Report Design menu or from 
the Report Design toolbar.

A column is added to the table with the formula property defined.

To move a column in a table
1 Select the header for the column in the table you want to move.

2 Move the cursor so it is over either the right or left border of the cell. The 
cursor changes to a four way arrow.

Click and drag the cursor to a spot between two other columns in the table. 
The location where the column would be moved is shown by changing the 
border between the two adjacent cells
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To move a column in a filtered table
You cannot move a column in a table that is filtered. You first need to remove 
the filters from the table. Then, you move the column. Finally, you set the 
filters again.

1 Click the arrow on the cell in a table from which you want to remove the 
filter. In Excel 2003, a cell that has a filter will have a blue arrow instead of 
a black arrow. In Excel 2007, a cell that has a filter will have a filter symbol 
instead of an arrow.

2 Open the Custom AutoFilter dialog box.

For Excel 2003, select Custom from the list.

For Excel 2007, select Text Filters > Custom Filter from the list.

3 Write down the current filter, so you can enter the same filter again later.

4 Click the Cancel button.

5 Remove the filter from the table.

For Excel 2003, click the arrow on the cell and click All from the list. The 
custom filter is removed.

For Excel 2007, click the arrow on the cell and click (Select All) from the 
list. Then, click OK. The custom filter is removed.

6 Do the steps in “To move a column in a table” on page 20.

7 Re-enter the custom filter. Do the steps in “To add a filter to an existing 
table” on page 17.

To add formatting to an existing template
You can add a page break or a sheet break to a template.

To add a page break:

1 Select the location in the template where you want to insert a page 
break.

2 Click Add Formatting > Page Break in the Report Design menu or in 
the Report Design toolbar.

Any information printed after a page break is printed on a new page.

To add a sheet break:
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1 Select the location in the template where you want to insert a sheet 
break.

2 Click Add Formatting > Sheet Break from the Report Design menu or 
from the Report Design toolbar.

Any information printed after a sheet break is printed on a new page. Also, 
this additional information is printed in a new tab in the Excel workbook.

To change time and date format
The date and time fields in the XML results file may not use the format that 
you want to use. The format that is in the XML results file is

YYYY-MM-DDTHH:MM:SS.XXXXX-WW:WW

Y - Year

M - Month

D - Day

T - The start of the Time section

H - Hour

M - Minute

S - Second

X - fractions of a second

W - Offset from the UTC (GMT) time. This number can be positive or negative 
depending on which side of the date line the time zone is in.

This topic shows you how to change this format to the following format:

YYYY-MM-DD HH:MM:SS

1 Open the XML Source window. 

For Excel 2003, click Data > XML > XML Source. You can also right-click 
one of the mapped columns and click XML > XML Source.

For Excel 2007, right-click one of the mapped columns and click XML > 
XML Source.

2 Find the date/time field in the XML Source that you want to add to the 
report. If the field is shown in bold in the XML Source window, it is already 
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being used in the report. You will need to switch to a different XML map to 
add this field to the report again.

3 Click and drag this field to an empty field in the report template. This field 
will be hidden and only used to hold the original information. It is best if 
you choose a location where only white space is shown in the report.

4 Click on the location where you want to add the date and time. If you want 
to add a date and time to a table, do the steps in “To add a formula column 
to an existing table” on page 19.

5 Type the following formula: =REPLACE(REPLACE(C1,17,18,””),11,1,” “). In this 
example, C1 is the location where the information from the XML source was 
placed. The “T” in the date and time field is replaced with a space and the 
parts of a second and the offset from the GMT time are removed. Please 
refer to the help for the REPLACE command in Excel for more information.

The following steps make the field where you placed the information from the 
XML source not visible. It may be useful to verify the changes before 
continuing. Do the steps in “To verify changes in a report” on page 8.

6 Click on the field where the information from the XML source was placed. 

7 Right-click this field and click Format Cells.

8 Change the pattern of this cell and the color of this cell. 

This field is actually being printed as white text on a white background, so 
it is not visible in the final report.

For Excel 2003:

a Click the Patterns tab.

b Select No Color for the Cell shading pattern by clicking the box that is 
white.

c Click the Font tab.

d Select white as the Color of the font.

For Excel 2007:

a Click the Fill tab.

b Select No Color for the Background Color.

c Click the Font tab.

d Select white as the Color of the font.

9 Click OK in the Format Cells dialog box.
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Using the Advanced Properties dialog box

The following tasks show you the features of the Advanced Properties dialog 
box.

“To set the report type” on page 24

“To make a sheet in the template a design sheet” on page 25

“To specify a graphic size” on page 25

“To keep text and the following table/graphic on the same page” on page 25

“To show a table vertically” on page 26

“To hide the column header row” on page 26

To set the report type
The report type indicates which type of report is created with this template. 
You can specify in which program this template is used. 

• The Quantitative Analysis program only uses templates that have the 
Report Type of Quantitative. 

• The Qualitative Analysis program uses templates that have the Report 
Type of QualAnalysis, QualCompound, AcqMethod, QualMethod, or Plot 
Window.

• The Data Acquisition program uses templates that have the Report Type of 
MS Tune or AcqMethod.

Other Report Types are used by other MassHunter programs.

The commands that are available in the Add Data and Add Graphics menus 
and toolbar change depending on what the Report Type is set to.

1 Click Advanced Properties from the Report Design menu or from the 
Report Design toolbar.

2 Click the Template tab.

3 Select the appropriate Report Type for the report that you are editing.

4 Click Close.
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To make a sheet in the template a design sheet
For a worksheet to be used when a report is printed, you need to mark the 
Active worksheet is a design worksheet check box and clear the Exclude 
from report check box.

1 Click Advanced Properties from the Report Design menu or from the 
Report Design toolbar.

2 Click the Design Worksheet tab.

3 Mark the Active worksheet is a design worksheet check box. If this 
checkbox is clear, then it is not used in a report.

4 Clear the Exclude from report check box. If this check box is marked, then 
this tab of the template is not included when a report is printed.

5 Click Close.

To specify a graphic size
1 Do the steps in “To add a mapped column to an existing table” on page 16. 

Select an item that starts with the word Graphic.

2 Click Advanced Properties from the Report Design menu or from the 
Report Design toolbar.

3 Click the Cell tab.

4 Click the Graphics button to include the actual graphic in the report.

5 Click one of the Graphic width relative to page width buttons. If you click 
1/4, then the width of the graphic is one fourth of the width of the page. If 
you select Full, then the width of the graphic is the entire page width.

6 Click Close.
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To keep text and the following table/graphic on the same page

1 Select the text that you want to connect to the table or graphics that follows 
it.

2 Click Advanced Properties from the Report Design menu or from the 
Report Design toolbar.

3 Click the Cell tab.

4 Click the Associate with following table or graphics button.

5 Click Close.

An alternative way to keep the text and table/graphics on the same page is by 
inserting a page break. If you want to insert a page break, do the steps in “To 
add formatting to an existing template” on page 21.

To show a table vertically
Normally, tables are printed horizontally. The label appears above the value in 
the table and the values are shown in a table. However, when you are printing 
a table like the Sample Table, you may wish to show the table vertically 
instead.

1 Select the table that you want to show vertically. 

2 Click Advanced Properties from the Report Design menu or from the 
Report Design toolbar.

3 Click the Table tab.

4 Mark the Table contents as text check box.

5 Type the number of columns you wish to use to show the information. If 
you want to show two pieces of information next to each other, you type 2.

6 Click Close.
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To hide the column header row

Normally, tables that are printed include both the header and the value. You 
can hide the header information if you want to.

1 Select the table from which you want to remove the header. 

2 Click Advanced Properties from the Report Design menu or from the 
Report Design toolbar.

3 Click the Table tab.

4 Mark the Hide header row check box.

5 Click Close.
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